Humanitec

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Degraded performance retrieving apps for some organizations
Resolved·Degraded performance

This incident has been resolved.

Fri, Jul 21, 2023, 11:56 AM
(2 years ago)
·
Affected components
Jul 21, 2023, 10:41 AM
11:56 AM
Updates

Resolved

This incident has been resolved.

Fri, Jul 21, 2023, 11:56 AM

Identified

The issue has been identified and a fix is being implemented.

Fri, Jul 21, 2023, 10:41 AM(1 hour earlier)