Resolved
This incident has been resolved.The root cause has been a faulty ingress configuration which has been removed now.
Investigating
We are currently investigating an issue with our ingress controller, which seems to cause unavailability of our platform in some cases.